IPSDK 1.5 and Linux Ubuntu 16.04

Discussions about the use of IPSDK

IPSDK 1.5 and Linux Ubuntu 16.04

Message par Franky » 24 Août 2017, 18:18

Hello all IPSDK users

I'm currently testing IPSDK 1.5 on several operating systems.

I did not have any particular problem installing / compiling the sample samples that you provide under Windows.
I have repeated the procedure under Linux (Ubuntu 16.04 LTS distribution), but when compiling the examples (with gcc-6.3.0) I have the errors in the final step of the executables link.

An idea / suggestion to solve the problem?

Thank you

Franky
Franky
 
Message(s) : 2
Inscription : 24 Août 2017, 18:12

Re: IPSDK 1.5 and Linux Ubuntu 16.04

Message par ReactivIP » 24 Août 2017, 18:41

Hello Franky

Thank you for your interest in IPSDK.
The Linux distribution we provided to you was compiled using a gcc version 4.8.
To use this distribution with a compiler 5.x or 6.x you will need to add the following definition when compiling: _GLIBCXX_USE_CXX11_ABI=0

For this you just need to modify the configuration of CMake before compilation (you will certainly have to activate the 'Advanced' mode):

Image

Please tell me if this solution corrects you problem.

Reactiv'IP technical Support
ReactivIP
Administrateur
 
Message(s) : 85
Inscription : 30 Avril 2013, 12:07

Re: IPSDK 1.5 and Linux Ubuntu 16.04

Message par Franky » 24 Août 2017, 18:51

Thank you very much.

Your solution solved the problem!

Franky
Franky
 
Message(s) : 2
Inscription : 24 Août 2017, 18:12


Retour vers IPSDK : sdk for very fast image processing

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité

cron